re = /(yes)/
str = 'on ok ok ok on
no ok no zip
zip ok no ok zop
zip ok zop no ok zap
zip no ok no'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end