re = /((?<=[a-z0-9])[A-Z]|(?!^)(?<!_)[A-Z](?=[a-z]))/m
str = 'camelCase
camelCase123
camelCASE
camel1Case
HTTPError
camelCaseD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end