re = /(?:\sco\s|\sco$)/m
str = 'A co is mine
A column is mine
my co
my column'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result