# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"COPD\sGOLD\s([0-9])([A-Z])?\b"
test_str = ("Infektexacerbierte COPD GOLD 2\n"
"COPD GOLD 2\n"
"COPD GOLD 3B\n"
"Betablocker wurden bei COPD GOLD 4 nicht verabreicht.\n\n"
"COPD Stadium D nach GOLD mit Emphysem\n"
"Risikogruppe B nach GOLD mit \\rrespiratorischer Globalinsuffizi\n"
"Virale infektexazerbierte COPD GOLD D\n"
"Exazerbierte COPD mit erforderlicher intermittierender BiPAP-Beatmung bei hyperkapnischen respiratorischen Insuffizienz\\rLungenemphysem, COPD Stadium GOLD 4\\\n"
"Risikoklasse D nach GOLD mit respiratorischer Partialinsuffizienz in Ruhe\n"
"m II-III, Risikogruppe D nach GOLD\n"
"COPD Stad. II nach GOLD$\n"
"rt. Bei bek. COPD St. IV nach GOLD stellte sich ein prolongierte\n"
"Beurteilung: COPD III nach GOLD Lungenemphysem. Keine asthmoi\n"
"m II-III, Risikogruppe D nach GOLD\n"
"COPD Stad. II nach GOLD\n"
"Bei bek. COPD St. IV nach GOLD stellte sich ein prolongierte\n"
"Beurteilung: COPD III nach GOLD Lungenemphysem. Keine asthmoi\n"
"OPD bekannt Grad 1 bis 2 nach GOLD , antiobstruktive Therapie mi")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.