// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)COPD\sGOLD\s([0-9])([A-Z])?\b").unwrap();
let string = "Infektexacerbierte COPD GOLD 2
COPD GOLD 2
COPD GOLD 3B
Betablocker wurden bei COPD GOLD 4 nicht verabreicht.
COPD Stadium D nach GOLD mit Emphysem
Risikogruppe B nach GOLD mit \\rrespiratorischer Globalinsuffizi
Virale infektexazerbierte COPD GOLD D
Exazerbierte COPD mit erforderlicher intermittierender BiPAP-Beatmung bei hyperkapnischen respiratorischen Insuffizienz\\rLungenemphysem, COPD Stadium GOLD 4\\
Risikoklasse D nach GOLD mit respiratorischer Partialinsuffizienz in Ruhe
m II-III, Risikogruppe D nach GOLD
COPD Stad. II nach GOLD$
rt. Bei bek. COPD St. IV nach GOLD stellte sich ein prolongierte
Beurteilung: COPD III nach GOLD Lungenemphysem. Keine asthmoi
m II-III, Risikogruppe D nach GOLD
COPD Stad. II nach GOLD
Bei bek. COPD St. IV nach GOLD stellte sich ein prolongierte
Beurteilung: COPD III nach GOLD Lungenemphysem. Keine asthmoi
OPD bekannt Grad 1 bis 2 nach GOLD , antiobstruktive Therapie mi";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}