package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^][]*]|\b(hello)\b`)
var str = `hello world [hello hello] world hello [world hello world hello] world hello [hello] hello
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}