re = /\[[^][]*]|\b(hello)\b/m
str = 'hello world [hello hello] world hello [world hello world hello] world hello [hello] hello
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end