#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{2}\/\d{2}\/\d{2,4}|\d{2}\/\d{2,4}|20\d{2}|\d{1,2} mois|\d{1,2} .{1,9} \d{2,4})"
Local $sString = "R1 = ([ée]ch[ée]ance|exp[eé]ritation|fin|terme) du bail " & @CRLF & _
"R1_bis = (\d{2}\/\d{2}\/\d{2,4}|\d{2}\/\d{2,4}|20\d{2}|\d{1,2} mois|\d{1,2} \w{1,9] \d{2,4})" & @CRLF & _
"" & @CRLF & _
"\d{1,2} .{1,9} \d{2,4}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"echéance du bail 3/6/9 30/09/20 " & @CRLF & _
"échéance du bail 06/2025" & @CRLF & _
"expéritation du bail 06/2025" & @CRLF & _
"terme du bail 31 août 2028 " & @CRLF & _
"terme du bail 31 novembre 2028 " & @CRLF & _
"fin du bail en 2027. desti" & @CRLF & _
"fin du bail 2021 environne" & @CRLF & _
"fin du bail en 2028 enviro" & @CRLF & _
"fin du bail dans 2 mois" & @CRLF & _
"fin du bail 2021 activités" & @CRLF & _
"(fin du bail 18 mois)" & @CRLF & _
"fin du bail le 13/04/2025" & @CRLF & _
"" & @CRLF & _
"(\d{2}\\d{2}\\d{2,4}" & @CRLF & _
"" & @CRLF & _
"\d{2} mois" & @CRLF & _
"" & @CRLF & _
"\d{1,2} \w{1,9] \d{2,4}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")