# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{2}\/\d{2}\/\d{2,4}|\d{2}\/\d{2,4}|20\d{2}|\d{1,2} mois|\d{1,2} .{1,9} \d{2,4})"
test_str = ("R1 = ([ée]ch[ée]ance|exp[eé]ritation|fin|terme) du bail \n"
"R1_bis = (\\d{2}\\/\\d{2}\\/\\d{2,4}|\\d{2}\\/\\d{2,4}|20\\d{2}|\\d{1,2} mois|\\d{1,2} \\w{1,9] \\d{2,4})\n\n"
"\\d{1,2} .{1,9} \\d{2,4}\n\n\n"
"echéance du bail 3/6/9 30/09/20 \n"
"échéance du bail 06/2025\n"
"expéritation du bail 06/2025\n"
"terme du bail 31 août 2028 \n"
"terme du bail 31 novembre 2028 \n"
"fin du bail en 2027. desti\n"
"fin du bail 2021 environne\n"
"fin du bail en 2028 enviro\n"
"fin du bail dans 2 mois\n"
"fin du bail 2021 activités\n"
"(fin du bail 18 mois)\n"
"fin du bail le 13/04/2025\n\n"
"(\\d{2}\\\\d{2}\\\\d{2,4}\n\n"
"\\d{2} mois\n\n"
"\\d{1,2} \\w{1,9] \\d{2,4}\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.