package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[1-9]\d{2}\-\d{3}\-\d{4}`)
var str = `208-123-4567
099-123-4567
280-123-4567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}