#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-?\d+(?:\.\d+)?"
Local $sString = "$ 8" & @CRLF & _
"$ 12.548" & @CRLF & _
"$ -8" & @CRLF & _
"$ -6.098" & @CRLF & _
"$ -59" & @CRLF & _
"$ 778" & @CRLF & _
"$ 73" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")