$re = '/-?\d+(?:\.\d+)?/m';
$str = '$ 8
$ 12.548
$ -8
$ -6.098
$ -59
$ 778
$ 73
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);