use strict;
my $str = 'Unit 345&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&--12 ';
my $regex = qr/((([Uu]nit|[Ss]tudio|[Ff]lat)?)([\s\t]{0,5})((\d+)(\&|\-)*(\d*)(\w*)(\w*)(\s*)(\w*)(\s*)(\w*)(\s*)([Ee]nd|[Gg]reen|[Cc]auseway|[Cc]heapside|[Cc]rescent|[Ss]treet|[Ll]ane|[Ww]alk|[Rr]oad|[Aa]venue|[Dd]rive|[Pp]ark|[Ww]ay|[Pp]lace|[Pp]arade|[Ii]ndustrial[Ee]state|[Tt]rading [Ee]state|[Hh]ouse|[Gg]reen))([\s\t]{0,5})(\w*)([\s\t]{0,5})(\w*)([\s\t]{0,5})(\w*)([\s\t]{0,5})(\w*)([\s\t]{0,5})(\w*)([\s\t]{0,5})(([A-Z0-9][A-Z0-9][A-Z0-9]?[A-Z0-9]? {1,2}[0-9][A-Z]{2})))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}