$re = '/((([Uu]nit|[Ss]tudio|[Ff]lat)?)([\s\t]{0,5})((\d+)(\&|\-)*(\d*)(\w*)(\w*)(\s*)(\w*)(\s*)(\w*)(\s*)([Ee]nd|[Gg]reen|[Cc]auseway|[Cc]heapside|[Cc]rescent|[Ss]treet|[Ll]ane|[Ww]alk|[Rr]oad|[Aa]venue|[Dd]rive|[Pp]ark|[Ww]ay|[Pp]lace|[Pp]arade|[Ii]ndustrial[Ee]state|[Tt]rading [Ee]state|[Hh]ouse|[Gg]reen))([\s\t]{0,5})(\w*)([\s\t]{0,5})(\w*)([\s\t]{0,5})(\w*)([\s\t]{0,5})(\w*)([\s\t]{0,5})(\w*)([\s\t]{0,5})(([A-Z0-9][A-Z0-9][A-Z0-9]?[A-Z0-9]? {1,2}[0-9][A-Z]{2})))/m';
$str = 'Unit 345&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&--12 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);