const regex = /(?<=\btrackingID\b=)\s*[^;\r\n]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\btrackingID\\b=)\\s*[^;\\r\\n]*', 'gm')
const str = `ErrorString : trackingID=jskdf-77sdkj-oij4-kerj43-lklfds; key1=lksfjsdkjfkslkdjf;key2=skjfjdkfj43jrkjskd;key4=lksfjsdkjfkslkdjf;key4=skjfjdkfj43jrkjskd;{\\"info\\":{\\"details\\":[{\\"code\\":\\"ABC23423\\",\\"messages\\":\\"msg:INVALID_ERROR\\",\\"timeStamp\\":\\"2019-08-30T15:03:43.668Z\\"}],\\"\$httpStatus\\":400},\\"status\\":400,\\"test\\":\\"ABC2342fdsff3\\"
ErrorString : key1=lksfjsdkjfkslkdjf;key2=skjfjdkfj43jrkjskd;key4=lksfjsdkjfkslkdjf;key4=skjfjdkfj43jrkjskd;{\\"info\\":{\\"details\\":[{\\"code\\":\\"ABC23423\\",\\"timeStamp\\":\\"2019-08-30T15:03:43.668Z\\"}],\\"\$httpStatus\\":400},\\"messages\\":\\"msg:INVALID_ERROR\\",\\"status\\":400,\\"test\\":\\"ABC2342fdsff3\\"trackingID=jskdf-77sdkj-oij4-kerj43-lklfds;
ErrorString : trackingID=jskdf-77sdkj-oij4-kerj43-lklfds; key1=lksfjsdkjfkslkdjf;key2=skjfjdkfj43jrkjskd;key4=lksfjsdkjfkslkdjf;key4=skjfjdkfj43jrkjskd;{\\"info\\":{\\"details\\":[{\\"code\\":\\"ABC23423\\",\\"timeStamp\\":\\"2019-08-30T15:03:43.668Z\\"}],\\"status\\":400,\\"\$httpStatus\\":400},\\"messages\\":\\"msg:INVALID_ERROR\\",\\"test\\":\\"ABC2342fdsff3\\"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}