use strict;
my $str = 'ErrorString : trackingID=jskdf-77sdkj-oij4-kerj43-lklfds; key1=lksfjsdkjfkslkdjf;key2=skjfjdkfj43jrkjskd;key4=lksfjsdkjfkslkdjf;key4=skjfjdkfj43jrkjskd;{\\"info\\":{\\"details\\":[{\\"code\\":\\"ABC23423\\",\\"messages\\":\\"msg:INVALID_ERROR\\",\\"timeStamp\\":\\"2019-08-30T15:03:43.668Z\\"}],\\"$httpStatus\\":400},\\"status\\":400,\\"test\\":\\"ABC2342fdsff3\\"
ErrorString : key1=lksfjsdkjfkslkdjf;key2=skjfjdkfj43jrkjskd;key4=lksfjsdkjfkslkdjf;key4=skjfjdkfj43jrkjskd;{\\"info\\":{\\"details\\":[{\\"code\\":\\"ABC23423\\",\\"timeStamp\\":\\"2019-08-30T15:03:43.668Z\\"}],\\"$httpStatus\\":400},\\"messages\\":\\"msg:INVALID_ERROR\\",\\"status\\":400,\\"test\\":\\"ABC2342fdsff3\\"trackingID=jskdf-77sdkj-oij4-kerj43-lklfds;
ErrorString : trackingID=jskdf-77sdkj-oij4-kerj43-lklfds; key1=lksfjsdkjfkslkdjf;key2=skjfjdkfj43jrkjskd;key4=lksfjsdkjfkslkdjf;key4=skjfjdkfj43jrkjskd;{\\"info\\":{\\"details\\":[{\\"code\\":\\"ABC23423\\",\\"timeStamp\\":\\"2019-08-30T15:03:43.668Z\\"}],\\"status\\":400,\\"$httpStatus\\":400},\\"messages\\":\\"msg:INVALID_ERROR\\",\\"test\\":\\"ABC2342fdsff3\\"';
my $regex = qr/(?<=\btrackingID\b=)\s*[^;\r\n]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}