const regex = /\b
(?:
Length\ +(?<Length>\d+(?:\.\d+)?)\ +(?:in|ft|cm|m)|
Width\ +(?<Width>\d+(?:\.\d+)?)\ +(?:in|ft|cm|m)|
Weight\ +(?<Weight>\d+)\ +(?:oz|lb|g|kg)
)
\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b
(?:
Length\\ +(?<Length>\\d+(?:\\.\\d+)?)\\ +(?:in|ft|cm|m)|
Width\\ +(?<Width>\\d+(?:\\.\\d+)?)\\ +(?:in|ft|cm|m)|
Weight\\ +(?<Weight>\\d+)\\ +(?:oz|lb|g|kg)
)
\\b', 'gm')
const str = `Width 3.5 in
Weight 10 kg
Length 20 m
Note I've set the 'x' (extended) flag to make it easier to view the regex.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}