re = /\b
(?:
Length\ +(?<Length>\d+(?:\.\d+)?)\ +(?:in|ft|cm|m)|
Width\ +(?<Width>\d+(?:\.\d+)?)\ +(?:in|ft|cm|m)|
Weight\ +(?<Weight>\d+)\ +(?:oz|lb|g|kg)
)
\b/mx
str = 'Width 3.5 in
Weight 10 kg
Length 20 m
Note I\'ve set the \'x\' (extended) flag to make it easier to view the regex.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end