using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[abcde])(?!.*?([abcde]).*\1).{5}$";
string input = @"Should pass:
abcde
afghi
fgahi
fghia
Should fail:
Too short:
abcd
Too long
abcdef
Missing required char:
fghij
Duplicates:
aaaaa
abcbc
afgha
fgaah";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}