re = /^(?=.*[abcde])(?!.*?([abcde]).*\1).{5}$/m
str = 'Should pass:
abcde
afghi
fgahi
fghia
Should fail:
Too short:
abcd
Too long
abcdef
Missing required char:
fghij
Duplicates:
aaaaa
abcbc
afgha
fgaah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end