re = /:(?:\s*(?!SCHEDULED)[A-Z]+)+/m
str = ':CITYNAMEONE SCHEDULED
:CITY NAME TWO
:CITYNAMETHREE
: '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end