#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)," & @CRLF & _
"(?P<CompanyName>\b(?:(?!\d{3,})[A-Z\d ])+\b)\s+" & @CRLF & _
"(?P<Reference>\b\d{1,18}\b)\s+" & @CRLF & _
"(?P<Type>[A-Z]+)"
Local $sString = ",11/12/2017,00-87-67 34849444,-27.00,ITEMRECEIVED,H2G2 929613292012071217 REF" & @CRLF & _
",02/01/2018,00-87-68 58493922,-1110.79,ITEMSENT,MIL P01 WOOLLIES 9221234545 DEG" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")