package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),
(?P<CompanyName>\b(?:(?!\d{3,})[A-Z\d ])+\b)\s+
(?P<Reference>\b\d{1,18}\b)\s+
(?P<Type>[A-Z]+)`)
var str = `,11/12/2017,00-87-67 34849444,-27.00,ITEMRECEIVED,H2G2 929613292012071217 REF
,02/01/2018,00-87-68 58493922,-1110.79,ITEMSENT,MIL P01 WOOLLIES 9221234545 DEG
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}