$re = '/^(?![0-9])[a-zA-Z0-9]*\ ?[a-zA-Z0-9]*$/m';
$str = 'Google
Car 401
Car401
012 Avenue
Central Park
34134';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);