re = /^(?![0-9])[a-zA-Z0-9]*\ ?[a-zA-Z0-9]*$/m
str = 'Google
Car 401
Car401
012 Avenue
Central Park
34134'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end