package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\w{32}_v2$`)
var str = `_________________________________v2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}