const regex = /^\w{32}_v2$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w{32}_v2$', '')
const str = `_________________________________v2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}