$re = '~{([^:{}]+)(:([^{}]+))?}~m';
$str = '/category/{aYes:bYes}/{cYes}/{dNo:}/{eNo:/{:fNo}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);