re = /{([^:{}]+)(:([^{}]+))?}/m
str = '/category/{aYes:bYes}/{cYes}/{dNo:}/{eNo:/{:fNo}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end