package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\[asciidoc](.*?)\[/asciidoc]`)
var str = `[asciidoc] here is some text to be filtered[/asciidoc]
a bit of text
[asciidoc]some text in a second block[/asciidoc]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}