import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[asciidoc](.*?)\\[/asciidoc]";
final String string = "[asciidoc] here is some text to be filtered[/asciidoc]\n"
+ "a bit of text\n"
+ "[asciidoc]some text in a second block[/asciidoc]";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}