import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{%\\s*(\\w+)\\b(?:(?!%\\}).)*%\\}(?:(?!\\{%)[\\s\\S]|(?R))*?\\{%\\s*end\\1\\s*%\\}";
final String string = "{% div %}\n"
+ " random text here\n"
+ " {% span class='test-1'%}{% small %}small text{% endsmall %}{% endspan %}\n"
+ " {% div %}second div{% enddiv %}\n"
+ "{% enddiv %}\n"
+ "{% span %}nothing{% endspan %}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}