$re = '/\{%\s*(\w+)\b(?:(?!%}).)*%}(?:(?!\{%)[\s\S]|(?R))*?{%\s*end\1\s*%}/m';
$str = '{% div %}
random text here
{% span class=\'test-1\'%}{% small %}small text{% endsmall %}{% endspan %}
{% div %}second div{% enddiv %}
{% enddiv %}
{% span %}nothing{% endspan %}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);