$re = '/^(?=.*?\bjack\b).*?\bjames\b.*/mi';
$str = 'jack and james
james and jack
john and jack
james and jim';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);