re = /^(?=.*?\bjack\b).*?\bjames\b.*/mi
str = 'jack and james
james and jack
john and jack
james and jim'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end