const regex = /(?m)^[^{}]*{\s*(?>"(?!status": "OK)[^{}"]++)+}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^[^{}]*{\\s*(?>"(?!status": "OK)[^{}"]++)+}', 'g')
const str = `{
"JMS Server": {
"message": "Successfully connected to JMS Server",
"status": "OK"
},
"Database": {
"message": "JDBC Connection failure",
"status": "CRITICAL",
"info": "No operations allowed after connection closed."
},
"Application": {
"message": "Application is up",
"status": "OK",
"info": "Application name = Testing"
}
}
{
"JMS Server": {
"message": "Successfully connected to JMS Server",
"status": "OK"
},
"Database": {
"message": "Database was successfully reached in 1ms",
"status": "OK"
},
"Application": {
"message": "IO Error Connection refused (Connection refused)",
"status": "CRITICAL",
"info": "URL = http://localhost/testing/healthcheck"
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}