use strict;
my $str = '{
"JMS Server": {
"message": "Successfully connected to JMS Server",
"status": "OK"
},
"Database": {
"message": "JDBC Connection failure",
"status": "CRITICAL",
"info": "No operations allowed after connection closed."
},
"Application": {
"message": "Application is up",
"status": "OK",
"info": "Application name = Testing"
}
}
{
"JMS Server": {
"message": "Successfully connected to JMS Server",
"status": "OK"
},
"Database": {
"message": "Database was successfully reached in 1ms",
"status": "OK"
},
"Application": {
"message": "IO Error Connection refused (Connection refused)",
"status": "CRITICAL",
"info": "URL = http://localhost/testing/healthcheck"
}
}';
my $regex = qr/(?m)^[^{}]*{\s*(?>"(?!status": "OK)[^{}"]++)+}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}