// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([A-Z]+[ -]){1,})(([A-Z][a-z]+[ \-]){1,})\- ([0-9]{2}.[0-9]{2}.[0-9]{4}) - ([A|B|C])").unwrap();
let string = "ABBEY Chantelle - 08.11.1995 - A
ANAND Toni-Grace - 04.09.1999 - A
ADCOCK ALVEY James - 12.04.1992 - C
ADLINGTON-JONES Robin Jacob Sebastian - 15.02.1999 - B
AFZAL Kiera - 25.04.2000 - B
AHMED Nisar Abu Ben Adhem - 16.08.2002 - C
AIRE-DEANE Christopher-James - 06.01.1997 - B
AL-MISRI Yaqoob - 23.07.2004 - C
ASTER Lily-May - 01.04.2010 - B
McQUEEN Stephen - 02.02.2001 - A";
let substitution = "\\1\\t\\3\\t\\5\\t\\6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}