import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:((?:0?[1-9]|[12]\\d|3[01])(?:\\s*(?:st|[rn]d|th))?)\\s*)?(Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|June?|July?|Aug(?:ust)?|Sep(?:t(?:ember)?)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\\s*(\\d{2}(?:\\d{2})?)\\s*[-—–]\\s*(?:((?:0?[1-9]|[12]\\d|3[01])(?:\\s*(?:st|[rn]d|th))?)\\s*)?(Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|June?|July?|Aug(?:ust)?|Sep(?:t(?:ember)?)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\\s*(\\d{2}(?:\\d{2})?)(?!\\d)";
final String string = "July 2014 - 28th August 2014\n"
+ "Jan 2012 - 3rd sep 2014\n"
+ "Jan 2008 - May 2012\n"
+ "Jan 2008 and May 2012";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}