const regex = new RegExp('\\b(?:((?:0?[1-9]|[12]\\d|3[01])(?:\\s*(?:st|[rn]d|th))?)\\s*)?(Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|June?|July?|Aug(?:ust)?|Sep(?:t(?:ember)?)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\\s*(\\d{2}(?:\\d{2})?)\\s*[-—–]\\s*(?:((?:0?[1-9]|[12]\\d|3[01])(?:\\s*(?:st|[rn]d|th))?)\\s*)?(Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|June?|July?|Aug(?:ust)?|Sep(?:t(?:ember)?)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\\s*(\\d{2}(?:\\d{2})?)(?!\\d)', 'gmi')
const str = `July 2014 - 28th August 2014
Jan 2012 - 3rd sep 2014
Jan 2008 - May 2012
Jan 2008 and May 2012`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}