using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?:NEF|RAF|ARW|CR2)$";
string input = @"File.nef
Cr2fake.jpg
file.arw
file.CR2
RAFFile.jpg
RAFFile.rAf
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}