package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\.(?:NEF|RAF|ARW|CR2)$`)
var str = `File.nef
Cr2fake.jpg
file.arw
file.CR2
RAFFile.jpg
RAFFile.rAf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}