import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<\\w+\\s*[^>]*)\\s(?!href|title|alt)[\\w\\-\\d]+=(?:(['\"]).*?\\1|\\w+)";
final String string = "<p></p><p>\n"
+ "Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. \n"
+ "</p>\n\n"
+ "<p> </p>\n"
+ "href=\"test\" Test\n"
+ "<p>At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p>\n"
+ "<a href=\"www.google.de\">Test</a>\n"
+ "<a href= 'www.google.de' onmouseover =\"alert('Test2')\" >Test2</a>\n"
+ "<b></b>\n"
+ "<ul>\n"
+ "<li>\n"
+ "Element 1\n"
+ "</li>\n"
+ "<li onmouseover='alert(\"Test this\")'>\n"
+ "Element 2\n"
+ "</li>\n"
+ "</ul>\n"
+ "<ol>\n"
+ "</ol>\n"
+ "<script>alert(\"Test\");</script>\n"
+ "<p title=\"test\"> </p>\n"
+ "<p onmouseover=\"alert('test')\">\n"
+ "<p>At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p>\n\n"
+ "<p onmouseover=\"test\" title=\"test\"> </p>\n\n"
+ "<p>At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p><p></p>\n"
+ " ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}