$re = '/(?<=<\w+\s*[^>]*)\s(?!href|title|alt)[\w\-\d]+=(?:([\'"]).*?\1|\w+)/m';
$str = '<p></p><p>
Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua.
</p>
<p> </p>
href="test" Test
<p>At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p>
<a href="www.google.de">Test</a>
<a href= \'www.google.de\' onmouseover ="alert(\'Test2\')" >Test2</a>
<b></b>
<ul>
<li>
Element 1
</li>
<li onmouseover=\'alert("Test this")\'>
Element 2
</li>
</ul>
<ol>
</ol>
<script>alert("Test");</script>
<p title="test"> </p>
<p onmouseover="alert(\'test\')">
<p>At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p>
<p onmouseover="test" title="test"> </p>
<p>At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p><p></p>
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;