package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bPAL\d+\b`)
var str = `TCNU1573105 HDPE HTA108 155 155 000893520918 PAL990 25.2750 MT 28.9750 MT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}