re = /\bPAL\d+\b/m
str = 'TCNU1573105 HDPE HTA108 155 155 000893520918 PAL990 25.2750 MT 28.9750 MT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end