$re = '/(\w+)\(\)\s*{(.*?)}(?:,|$)/s';
$str = ' hasSelection() {
return this.selected.length;
},
btnText() {
return \'Pay \' + this.selected.length + \' Bills\';
},
transactionExplorerUrl() {
if (baConfig.etherenetExplorerUrl) {
return baConfig.etherenetExplorerUrl + this.transactionId;
} else {
return \'https://etherscan.io/tx/\' + this.transactionId;
}
},
filteredWallets() {
return this.wallets.filter(m => m.bulkSend && m.bulkSend.enabled);
}';
$subst = "get $1() {$2}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;