# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w+)\(\)\s*{(.*?)}(?:,|$)"
test_str = (" hasSelection() {\n"
" return this.selected.length;\n"
" },\n"
" btnText() {\n"
" return 'Pay ' + this.selected.length + ' Bills';\n"
" },\n"
" transactionExplorerUrl() {\n"
" if (baConfig.etherenetExplorerUrl) {\n"
" return baConfig.etherenetExplorerUrl + this.transactionId;\n"
" } else {\n"
" return 'https://etherscan.io/tx/' + this.transactionId;\n"
" }\n"
" },\n"
" filteredWallets() {\n"
" return this.wallets.filter(m => m.bulkSend && m.bulkSend.enabled);\n"
" }")
subst = "get $1() {$2}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.