#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^BEGIN\b.*(?:\r?\n(?!(?:BEGIN|END)\b).*)*\r?\nEND"
Local $sString = "Some_text Some_text 1 2 3" & @CRLF & _
"BEGIN Some_text Some_text" & @CRLF & _
"44 76 1321" & @CRLF & _
"Some_text Some_text" & @CRLF & _
"END Some_text" & @CRLF & _
"Some_Text Some_text 1 4 5" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")