import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^BEGIN\\b.*(?:\\r?\\n(?!(?:BEGIN|END)\\b).*)*\\r?\\nEND";
final String string = "Some_text Some_text 1 2 3\n"
+ "BEGIN Some_text Some_text\n"
+ "44 76 1321\n"
+ "Some_text Some_text\n"
+ "END Some_text\n"
+ "Some_Text Some_text 1 4 5\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}